Problem with cached service worker

how can i force wonderpush to pull a non-cached version of service worker?
right now its pulling my cached version. usually i would use ?v=1.1 query string or something like that

Hi,

First off, make sure you follow this article: Service Worker integration.
Using this article, you can make sure WonderPush won’t register it’s own default service worker intead of yours.

You can also use the serviceWorkerUrl option to add a cache buster query string.
But that’s not really the best way to bust cache while developing . You have a Chrome option for that, forcing a reload:
image

Best,